Delivery Delays
Incident Report for SMTP2GO
Resolved
A fix has been implemented, and all emails should now be delivered.
Posted Aug 22, 2024 - 20:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 22, 2024 - 17:01 UTC
Investigating
We are currently investigating delays associated with one mail server. Other mail servers are not affected.
Posted Aug 22, 2024 - 15:43 UTC
This incident affected: Email sending (SMTP service).