Issues with email delays affecting some accounts on EU servers
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 20:50 UTC
Monitoring
A fix has been put in place and any queued emails will be delivered soon. We'll continue working on this over the next few days until a full resolution is in place.
Posted Apr 12, 2024 - 14:39 UTC
Investigating
Our developers have discovered an issue with some of our European in-servers which is causing slight delays. Affected emails will show as "Processed" on the account Activity Page. The issue is being investigated.
Posted Apr 12, 2024 - 09:35 UTC
This incident affected: Email sending (SMTP service).