Messages Queued as 'Processed'

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 10:10 UTC

Monitoring

The issue has been identified and addressed
Posted Jul 01, 2026 - 10:01 UTC

Investigating

We are currently investigating an issue with email delivery
Posted Jul 01, 2026 - 09:42 UTC
This incident affected: Email sending (SMTP service).