"Processed" Emails (EU)

Incident Report for SMTP2GO

Resolved

This incident has been resolved.

Any remaining "Processed" emails will be delivered as quickly as possible.

The root cause has been identified as network maintenance related to the addition of new servers to the European network. We appreciate your patience and will provide further updates as necessary.
Posted Oct 23, 2024 - 12:45 UTC

Identified

Some European users may encounter delays in email delivery, where emails are shown as "Processed."

Our development team is aware of the issue and is actively working on a resolution with the highest priority.
Posted Oct 23, 2024 - 12:08 UTC
This incident affected: Email sending (SMTP service).