Processed Emails (AU)

Incident Report for SMTP2GO

Resolved

This incident has now been resolved.

New emails should flow as normal. Previously processed emails may take a little longer to update.
Posted Apr 30, 2026 - 08:35 UTC

Identified

Some users may experience delays and see "Processed" emails on their Activity feed.

Our developers have identified the issue and are implementing a fix.
Posted Apr 30, 2026 - 06:25 UTC
This incident affected: Email sending (SMTP service).