Mail Processing Issue
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 23:13 UTC
Monitoring
The issue was identified as a queue balancing. Server redistribution has reduced queuing. We are seeing major improvement to delivery, but will keep monitoring.
Posted Sep 13, 2023 - 22:57 UTC
Identified
Email processing has temporarily slowed, the issue is being rectified. More information to follow as it comes to hand.
Posted Sep 13, 2023 - 21:49 UTC
This incident affected: Email sending (SMTP service).