Cloudflare Outage (external issue)
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:39 UTC
Investigating
Due to an outage at Cloudflare, our ticket and phone support systems, hosted by Zendesk and TalkDesk, have been affected. For the time being, we are unable to receive calls, chats, or tickets. If you need to reach us, please email [email protected] and we will respond as soon as the issue has been resolved.
Posted Jun 21, 2022 - 07:21 UTC